# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^[\t ]*host[\t ]+(.+?)[\t ]*\n(?:(?!(?:^[\t ]*#.*\n)*[\t ]*host\b)[\t ]*(?:(\w+)\b(?:[\t ]*=[\t ]*|[\t ]+)(.*)|#.*)?(?:\n|\Z))+"
test_str = ("Host test \n"
" Hostname test.domain.com\n"
" User james\n"
" Port 22\n"
" # Comment\n"
" IdentityFile ~/.ssh/key.pub\n\n"
"# With 2 aliases\n"
"Host test2 test-2\n"
" Hostname test2.domain.com\n"
" User = james\n"
" Port=22\n"
" # Port 23\n"
" IdentityFile = ~/.ssh/key2.pub\n\n"
"# For all hosts except test2, activate compression and set log level:\n"
"Host * !test2\n"
" Compression yes\n"
" LogLevel INFO\n\n"
" IdentityFile ~/.ssh/id_rsa\n\n"
"Host *.sweet.home\n"
" Hostname 192.168.2.17\n"
" User tom\n"
" IdentityFile \"~/.ssh/id tom.pub\" # If has spaces, then quote it.\n\n"
"# With a lot of spaces between lines\n"
"Host localhost\n\n"
" Hostname 127.0.0.*\n\n"
" IdentityFile ~/.ssh/id_rsa\n\n"
"# Without empty lines between Host definitions:\n"
"Host dummy\n"
" Hostname ssh.dummy.com\n"
" User user\n"
"Host dummy2\n"
" Hostname ssh.dummy2.com\n"
" User user")
matches = re.finditer(regex, test_str, re.IGNORECASE | re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.