const regex = /^(?!\s*-\s+)(?:(?:\([^)]*\)|<[^>]*>(?:[^<]|<[^>]*>)*?<\/[^>]*>|`[^`]*`|\{[^}]*\}|[^`{<(.\n])+)(?:\.(?=[\s\n]|$)|(?<!:)(?=\n))/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!\\s*-\\s+)(?:(?:\\([^)]*\\)|<[^>]*>(?:[^<]|<[^>]*>)*?<\\\/[^>]*>|`[^`]*`|\\{[^}]*\\}|[^`{<(.\\n])+)(?:\\.(?=[\\s\\n]|$)|(?<!:)(?=\\n))', '')
const str = `See Unit Tests.
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}