package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)List size:\s(?<sum>\d+)`)
var str = `||pool-2-thread-1|| INFO com.tmobile.sfdc.reports.service.OpportunityService - OPPORTUNITY_JOB: List size: 41
||pool-2-thread-1|| INFO com.tmobile.sfdc.reports.service.OpportunityService - OPPORTUNITY_JOB: List size: 140`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}