re = /(\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3})/m
str = '192.168.1.1 May 14 00:01:44 kern warning kernel DROP IN=eth0 OUT= MAC=38:2c:4a:cb:e2:40:10:e8:78:aa:89:ba:08:00 SRC=185.216.140.6 DST=90.149.222.18 LEN=40 TOS=0x00 PREC=0x00 TTL=248 ID=54321 PROTO=TCP SPT=5'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end