package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[1-5]`)
var str = `1562351`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}