# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(\d+(?:\.\d{1,3})?)"
test_str = ("23.554656561568181681916651651615618\n\n"
"42.8865465465\n"
"468\n\n"
"40.541222\n\n"
"0\n\n"
"50")
subst = "$1%"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.