import re
regex = re.compile(r"(?<!\.)[a-z]{3,5}-\d{3}", flags=re.IGNORECASE)
test_str = "fjv5545.com-0528nhdfb129-h264.mp4"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")