// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?siU)\[url=.*\[/url\]").unwrap();
let string = "[URL=\"www.example.com\"]
UPDATE[/URL]
07-Ghost [HD 720p]
.Hack// Gift
.Hack// Returner
.Hack// Root [HD 720p]
.Hack//Liminality
.Hack//Quantum [BD 1080p]
.Hack//Sekai No Mukou Ni [BD 1080p][10 Bit]
.hack//Sign
.hack//Tasogare no Udewa Densetsu
.hack∕∕G.U. Trilogy [Blu-ray 1080p]
1+2 = Paradise
1001 Nights [ No Sub]
11 Eyes + OVA [Blu-ray 720p]
12-Sai. ~Kiss, Kirai, Suki~ OVA
2x2 shinobuten
3000 Leagues in Search of Mother
30-sai no Hoken Taiiku [Blu-ray 720p]
3x3 Eyes OVA 1
3x3 Eyes OVA 2
5 Centimeter Per Second [BD 1080p]
6 Angel
8 Man - After The Perfect Collection [Engdub]
A Letter to Momo [BD 1080p]
A Little Snow Fairy Sugar Special
A Piece of Phantasmogaria [DVD Version] [10 bits]
A Restaurant of Many Orders
A Tree Of Palme
A.D. Police
A.LI.CE
AA! Megami-sama - Sorezore no Tsubasa [Update to better Version]
AA! Megami-sama - Takakau Tsubasa
AA! Megami-sama / Ah My Goddess
AA! Megami-sama OVA
AA! Megami-sama Special / Ah My Goddess Special
Accel World [Blu-ray 720p]
Accel World EX + SPECIAL [Blu-ray 720p-1080p]
Acchi Kocchi [Blu-ray 720p]
Ace wo Nerae! The Movie : Best! (Aim For The Ace The Movie)
A-Channel + Special [Blu-ray Version 108p]
Adieu Galaxy Express 999
Aeon Flux - Deutoronopia, End Sinister,Ether Drift Theory,Reraizure [No Sub/Eng Dub]
Afro - Ken
Afro Samurai Movie [BD 720p]
Afro Samurai Resurrection [BD 1080p]
After School In The Teachers Lounge Ova 1 & Ova 2
After School Pleiades
Agent Aika Naked Mission
Agent Aika Naked Mission - Special Trials [LQ]
Ah, My Beautifull Girl Mary
Ai Mai Mi [HD 720p]
Ai Mai! Moe Can Change! OVA
Ai Yori Aoshi
Ai Yori Aoshi Enishi
Ai Yori Aoshi Miyuki
Aika R-16 Virgin Mission
Aika Zero OVA [HD 720p]
Aikatsu! [HD 720p]
Aim for the Ace!
Air [BD 720p] [10 bits]
Air Gear + Special
Air Master
Air Summer Special
Air Theatrical Feature
Aishiteruze Baby
Aiura [Blu-ray 720p]
Aiura [HD 1080p]
Ajimu Kaigan Monogatari
Akage No Anne
Akage No Anne Parody
Akagi
Akahori Gedou Hour Rabuge
Akai Kiba Blue Sonnet
Akane Maniax
Akane-Iro ni Somaeu Saka + OVA
Akazukin Cha Cha
Akazukin Cha Cha OVA
AKB0048 [Blu-ray 720p]
AKB0048 Next Stage [Blu-ray 720p]
Aki Sora ~In a Dream~
Aki Sora OVA
Akikan + OVA
Akira
Akira Special Edition
Aku no Hana [HD 1080p]
Aku No Hana [Blu-ray 1080p]
Alakazam The Great Movie
Alexander Senki
Alien 9
Allison to Lilia
Always My Santa
Amaenaideyo
Amaenaideyo Katsu
Amagami SS [BD 720p]
Amagami SS Special
Amagami SS+ [BD 1080p] [10 bits]
Amainaide Yo!
Amatsuki
Amazing Nurse Nanako
Amazing Nuts!
Amnesia [Blu-ray 720p]
Amnesia [HD 720p]
Amon Saga
Amon The Devil Apocalypse / Amon - Apocalypse of Devilman
Ancient Book of Ys
Ancient Book of Ys II
Angel Beats [BD 1080p]
Angel Cop
Angel Heart
Angel Links
Angel Sanctuary
Angelic Layer
Angelique - Memoir of White Wings
Angelique - When The Heart Awakens
Angelique ~Kagayaki no Ashita~ OVA
Angel's Egg
Angel's Feather Ova 1 & Ova 2
Angel's Tail
Ani Kuri [HD 1080p]
Animal Crossing
Animal Detective kiruminzoo [HD 720p]
Animation Runner Kuromi
Animatrix (2003)
Anime Mirai 2010 (Project A) - Ojisan No Lamp [HD 720p]
Anime Mirai 2010 (Project A) - Super Veggie Torracman [HD 720p]
Anime Mirai 2010 (Project A) - Wardrobe Dweller [HD 720p]
Anime Mirai 2010 (Project A) - Kizuna Ichigeki [HD 720p]
Anime Mirai 2012 - Buta [HD 720p]
Anime Mirai 2012 - Dudu the Floatie [HD 720p]
Anime Mirai 2012 - Minding My Own Business [HD 720p]
Anime Mirai 2012 - Wasurenagumo [HD 720p]
Anime Mirai 2013 - Arve Rezzle -Kikaijikake no Yoseitachi— [Blu-ray 720p]
Anime Mirai 2013 - Death Billiards [Blu-ray 1080p]
Anime Mirai 2013 - Little Witch Academia [Blu-ray 1080p]
Anime Mirai 2013 - RYO [Blu-ray 1080p]
Anime Mirai 2014 - Chronus [HD 1080p]
Anime Mirai 2014 - Harmonie [Blu-ray 1080p]
Anime Sanjushi (Three Musketeers)
Anju to Zushiou Maru
Ankokushin Densho Takegami
Ano Hi Mita Hana no Namae wo Bokutachi wa Mada Shiranai [BD 1080p] [10 bits]
Ano Ko ni 1000% - OVA
Ano Natsu De Matteru / Waiting in the Summer [BD 1080p]
Anokoku Shinwa [Dub English / Nos Sub]
Another : The Other -Inga- [Another Ova Ep.00] [BD 720p]
Another [BD 720p] [10 bits]
Antique Bakery [HD 720p]
Antique Heart OVA + Extra
Anyamal Tantei Kiruminzoo [HD 720p]
Ao no Exorcist - Kuro no Iede [BD 720p]
Ao no Exorcist [BD 720p]
Ao No Exorcist The Movie [BD 720p]
Aoi Bungaku [BD 720p]
Aoi Hana [HD 720p]
Aoi Sekai no Chuushin de [HD 1080p]
Aoki Densetsu Shoot !
Appleseed (OVA)
Appleseed The Movie 2004
Appleseed XIII [BD 1080p]
Aquarian Age
Aquarian Age Omake
Aquarian Age Saga II ~ Don't Forget Me... ~
Aquarion Evol [Blu-ray 720p]
Ar Tonelico OVA
Araisho Private High School Student Council Executive Committee OVA
Arakawa Under The Bridge [BD 720p]
Arakawa Under The Bridge x Bridge [BD 720p]
Arashi no Yoru ni [Blu-ray Version 720p]
Arata Kangatari [HD 1080p]
Arata-naru Sekai - World's/Start/Load/End - Future [BD 720p]
Arc The Lad
Arcade Gamer Fubuki
Arcadia Of My Youth
Arcana Famiglia [HD 720p]
Area 88
Argento Soma
Argento Soma - Phase Ex
Aria The Animation
Aria The Natural
Aria The Origination
Aria The OVA : Ariette
Ariel Visual OVA
Arion
Armed Librarians - The Book of Bantorra (Tatakau Shinso)
Armitage III
Armitage III : Dual Matrix [No Sub/Eng Dub]
Armitage III : Poly Matrix [No Sub/Eng Dub]
Armitage III OVA
Armor Hunter Mellowlink
Armor soldier Merrowlink OVA 1
Armored Fleet Dairugger XV
Armored Troopers Votoms - Alone Again [Blu-ray 1080p]
Armored Troopers Votoms - Big Battle
Armored Troopers Votoms - Case;IRVINE [Bluray 1080p]
Armored Troopers Votoms - Finder [Blu-ray 1080p]
Armored Troopers Votoms - Pailsen Files
Armored Troopers Votoms Movie - The Last Red Shoulder [LQ]
Armored Troopers Votoms Stage I
Armored Troopers Votoms Stage II
Armored Troopers Votoms Stage III
Arpeggio of Blue Steel - Ars Nova [HD 1080p]
Arrow Emblem - Super Grand Prix - Special [No Sub/English Dub]
Arslan Senki
Art Of Fighting
Asa Made Jugyou Chu! OVA [BD 1080p]
Asagiri No Miko
Asatte no Houkou
Ashita No Joe [HD 720p]
Ask Dr. Rin!
Asobi ni Iku Yo! [BD 720p]
Asobi ni Iku Yo! Asobi ni Oide OVA [BD 720p]
Assassination Classroom - OVA
Assassination Classroom (OVA)
Assemble Insert (ova)
Association Robot Goku
Astarotte no Omocha! (BD 720p)
Astarotte no Omocha! EX (BD 720p)
Astro Fighter Sunred + Suplement
Asu no Yoichi
Asura [Blu-ray 720p]
Asura's Crying [720p]
Asura's Crying 2nd [720p]
Atama Yama
Aura - Maryuuinkouga Saigo no Tatakai [Blu-ray 1080p]
Aura Battler Dunbine
Aurora
Avatar The Last Airbender : Book 1 water,Book 2 Earth,Book 3 Fire
Avatar The Legend of Korra : Book Water [HD 720p]
Avenger
Ayakashi
Ayakashi Japanese Classic Horror
Ayane's High Kick
Ayashi No Ceres
Azumanga Daioh
Azumanga Daioh Very Short Movie
Azumanga Daioh Web
B Gata H Kei [Blu-ray 720p]
Babel II Beyond Infinity Episode
Baby Love
Baccano [BD 1080p]
Baka to Test to Shoukanjuu [BD 720p]
Baka to Test to Shoukanjuu Matsuri [BD 720p]
Baka to Test to Shoukanjuu Ni! [BD 1080p] [10 bits]
Bakemonogatari [Blu-ray 720p]
Bakugan Battle Brawlers [ No Sub/Eng Dub]
Bakuman 1 [HD 720p]
Bakuman 2 [HD 720p][10 Bits]
Bakuman 3 [HD 720p]
BAKUMATSU GIJINDEN ROMAN [HD 720p]
Bakumatsu Kikansetsu Irohanihoheto
Bakuretsu Hunter OVA
Bakuretsu Tenshi
Bakuretsu Tenshi Infinity
Baldr Force Exe Resolution
Bamboo Blade
Banner of the Stars
Bannou Bunka Neko Musume Nuku - Nuku Dash
Bannou Bunka Neko Musume Nuku - Nuku OVA
Bannou Bunka Neko Musume Nuku - Nuku TV Series
BAOH The Movie
Barefoot Gen
Bari Bari Densetsu - Movie
Bartender [HD 720p]
Basilisk
Basquash! [HD 720p]
Bastard
Battle Angel
Battle Angel Alita
Battle Arena Toshinden
Battle B-Daman [English DUB-No Sub]
Battle Girls - Time Paradox [BD 720p]
Battle Programmer Shirase
Battle Royal High School
Battle Skipper
Battle Spirits - Shounen Toppa Bashin
Bavel No Hon
Bayonetta - Bloody Fate [Blu-ray 720p]
BB Fish
Beck [BD 1080p]
Beelzebub [HD 720p]
Beet The Vandel Buster
Beet The Vandel Buster Excellion
Ben-To [BD 720p]
Berserk
Berserk Golden Age Chapter I - Egg of the Supreme Ruler [BD 1080p] [10 bits]
Berserk Golden Age Chapter II - The Capture of Doldrey [Blu-ray 1080p]
Berserk Golden Age Chapter III - Advent [Blu-ray 1080p]
Berserk Outtakes [No Sub/Eng Dub]
Betterman
Beyblade Season 1 [English DUB-No Sub]
Beyblade Season 2 [English DUB-No Sub]
Beyblade Season 3 [English DUB-No Sub]
Beyblade The Movie - Decisive Battle! Takao VS Daichi [No Sub/English DUB]
Beyblade The Movie 2 - Sol Blaze, The Scorching Hot Invader!
Beyond The Clouds The Promised Place [BD 1080p]
Big Wars
Binbou Shimai Monogatari
Binbougami ga! [BD 720p][10 Bits]
Binchotan
Binchou Tan OVA : Aozora Ni Wasuremono+Marching Song
Bio Hunter
Birdy The Mighty Decode
Birdy The Mighty OVA
Black Blood Brothers
Black Cat
Black Heaven
Black Jack 21
Black Jack OVA
Black Jack Special - Lost Episodes
Black Jack The Movie
Black Jack The Movie - Dr. Pinoco Adventure
Black Jack The Movie - Two Doctors Of Darkness
Black Jack TV Series
Black Lagoon [BD 720p]
Black Lagoon Omake Short
Black Lagoon OVA - Roberta's Blood Trail [BD 720p]
Black Lagoon The Second Barrage [BD 720p]
Black Magic M66 Movie
Black Rock Shooter [BD 720p][10 bits]
Black Rock Shooter Ova [BD 1080p]
Blade
Blade of the Phantom Master
Blame +Extra
Blassreister [HD 720p]
BlazBlue - Alter Memory [HD 720p]
Blazing Transfer Student (Honoo No Tenkousei)
Bleach
Bleach Movie 1: Memories of Nobody [BD 1080p]
Bleach Movie 3: Fade to Black [BD 1080p]
Bleach Movie 4: The Hell Verse [BD 720p]
Bleach OVA : The Sealed Sword Frenzy
Blood Lad [HD 720p]
Blood Lad EX [Blu-ray 720p]
Blood Reign
Blood The Last Vampire [No Sub-Eng Dub]
Blood+
Blood-C [BD 720p] [10 bits]
Blood-C Movie - The Last Dark [BD 1080p]
Blossom [BD 1080p]
Blue Dragon - Tenkai no Shichi Ryuu
Blue Drop
Blue Flames OVA 1989
Blue Gender
Blue Seed
Blue Seed 2
Blue Seed Omake
Blue Submarine No 6 [HD 720p]
Body Jack OVA
Boku no Imouto wa Osaka Okan [HD 720p]
Boku No Marie
Boku No Sexual Harassment (Yaoi)
Boku Otaryman
Boku Wa Imouto Ni Koi Wo Suru
Boku Wa Konomana Kaeranai
Boku wa Tomodachi ga Sukunai [BD 720p]
Boku wa Tomodachi ga Sukunai NEXT [Blu-ray 720p]
Bokura Ga Ita [DVD Version]
Bokurano
Bokusatsu Tenshi Dokuro-chan (OVA)
Bokusatsu Tenshi Dokuro-chan 2 (OVA)
Boogiepop Phantom
Boogiepop Phantom OVA
Bottle Fairy
Bottom Biting Bug [HD 720p]
Boys Be... Special : Missing Scene
Boys Be…
Brain Powerd
Brave 10 [BD 720p]
Break Blade [BD 1080p]
Brigadoon
Bronze
Brothers Conflict [HD 720p]
BTOOOM! [Blu-ray 720p]
BT'x
BT'x Neo
Bubblegum Crash
Bubblegum Crisis 2032
Bubblegum Crisis 2040
Buddha Saitan - Movie [Blu-ray 720p]
Buddy Complex [HD 720p]
Bungaku Shoujo - Kyou no Oyatsu - Hatsukoi [BD 720p]
Bungaku Shoujo Movie [BD 720p]
Burn Up Excess
Burn Up Scramble
Burn Up W
Bus Gamer
Bushou Shinki OVA [BD 720p]
Busou Renkin
Busou Shinki [Blu-ray 720p]
Busou Shinki Moon Angel [BD 720p]
Buttobi CPU
Buzzer Beater (Basketball)
Buzzer Beater 2007
C - The Money of Soul and Possibility Control [BD 720p]
C3 - Cube x Cursed x Curious [BD 720p] [10 bits]
California Crisis: Gun Salvo
Call Me Tonight OVA
Campione! [Blu-ray 720p]
Canaan [Blu-ray 720p]
Canary (Ova)
Candy Boy
Candy Boy (ONA)
Candy Boy EX 2
Candy Candy The Movie
Candy Candy TV (Complete)[LQ]
Canvas 2 Special : Motif Of Sepia
Canvas 2nd
Capeta
Captain Harlock - Harlock Saga
Captain Harlock - Mystery of the Arcadia [Blu-ray 1080p]
Captain Harlock - Space Pirate Captain Harlock [2013][Blu-ray 1080p]
Captain Harlock - Waga Seishun no Arcadia - Movie [Blu-ray 720p]
Captain Harlock Endless Orbit SSX
Captain Herlock
Captain Tsubasa OVA 1 - Euro Finals
Captain Tsubasa OVA 2 - World War
Captain Tsubasa OVA 3 - Holland's Angel Wings
Captain Tsubasa Road to 2002
Cardcaptor Sakura [BD 720p]
Cardcaptor Sakura Memorial
Cardcaptor Sakura Movie 1 + Movie 2 Sealed Card [BD 720p]
Cardfight!! Vanguard
Cardfight!! Vanguard - Asia Circuit [HD 720p]
Cardfight!! Vanguard - Link Joker [HD 720p]
Carnival Phantasm [BD 1080p] + Special
Casshan Robot Hunter (1994)
Casshern Sins
Cat Shit One
Cat Soup OGM (Nekojirou)
Cat's Eye
CB Chara Go Nagai World
Cencoroll
Cencoroll OVA
Centurions [No Sub/Eng Dub]
Chance Pop Session
Chance Triangle
Chaos Head [HD 720p]
Charady's Daily Joke
Cherry no Manma
Chevalier
Chibi Maruko-chan Movie (1990)
Chicchana Yukitsukai Sugar
Chihayafuru [BD 720p]
Chihayafuru 2 [HD 1080p]
Chihayafuru 2 OAD
Chikyuu ga Ugoita HI (The Day the Earth Moved)
Chinese Ghost Story
Chip And Dale - Rescue Rangers Season 1 Complete [English Dub]
Chi's New Address
Chi's Sweet Home
Chi's Sweet Home - (OVA)
Chitose Get You! [HD 720p]
Chiyoko Millennial Actress
Chobits [BD 720p]
Chocolate Underground
Chocotan! [SP][BD 1080p]
Chocotto Sister
Chocotto Sister Special
Chokkyuu Hyoudai Robot Anime: Straight Title [HD 1080p]
Choujikuu Kidan Southern Cross
Choujuu Kishin Dancougar TV
Chouyaku Hyakuninisshu Uta Koi [HD 720p]
Chrono Crusade
Chrono Crusade
Chrono Crusade +Zero
Chrono Trigger OVA [LQ]
Chu-Bra!! [BD 720p]
Chuumon no Ooi Ryouriten (1993)
Chuunibyou demo Koi ga Shitai! [Blu-ray 720p]
Chuunibyou demo Koi ga Shitai! ~Depth of Field~ [Blu-ray 720p]
Chuunibyou Demo Koi Ga Shitai! Ova [Blu-ray 1080p]
Chuunibyou Demo Koi ga Shitai! Ren - Shiritori Under the Kotatsu [Blu-ray 1080p]
Chuunibyou demo Koi ga Shitai! Ren [HD 720p]
Chuunibyou demo Koi ga Shitai! Ren Lite [HD 720p]
Chuunibyou demo Koi ga Shitai! The Movie [Blu-ray 1080p]
Chuunibyou demo Koi ga Shitai! The Movie Lite [Blu-ray 1080p]
City Hunter
City Hunter - Kinkyu Namachukei! Kyouakuhan Saeba Ryo no Saigo
City Hunter 1991
City Hunter 2
City Hunter 3
City Hunter The Movie 1 - .357 Magnum
City Hunter The Movie 2 - Bay City Wars
City Hunter The Movie 3 - Secret Service
City Hunter The Movie 4 - Million Dollar Conspiracy
City Hunter The Movie 5 - Goodbye My Sweetheart
City Hunter The Movie 6 - Death Of Evil Ryo Saeba
Clamp Gakuen Tanteidan
Clamp In Wonderland 2
Clannad [BD 1080p]
Clannad After story [BD 720p]
Clannad Movie
Claymore [BD 720p]
Cleopatra DC OVA
Clockwork Fighter - Himou's War
Clover
Code E
Code Geass [Blu-ray 720p]
Code Geass Hangyaku no Lelouch R2 [Blu-ray 720p]
Code Geass Nunnally in Wonderland [BD 1080p] [10 bits]
Code Geass: Boukoku no Akito 1 - Yokuryuu wa Maiorita [Blu-ray 1080p]
Code Geass: Boukoku no Akito 2 - Hikisakareshi Yokuryuu [Blu-ray 1080p]
CØDE:BREAKER [HD 720p][10 Bits]
Coicent [BD 720p]
Colorful [BD 1080p]
Combattler V
Combustible Campus Guardress
Comic Party
Comic Party Revolution OVA
Comic Party Special
Compiler 2 Festa OVA [No Sub/Engdub]
Computer Kakumei
Condor Heroes Season I
Condor Heroes Season II
Cooking Master Boy Complete
Copihan
Coppelion [HD 720p]
Corpse Party Missing Footage [Blu-ray 1080p]
Corpse Party Tortured Souls - Bougyakusareta Tamashii no Jukyou [BD 1080p]
Cosmopolitan Prayers (Cosprayers)
Cosmopolitan Prayers OVA
Cosmopolitan Prayers The Movie (Cosprayers)
Cosmos Pink Shock
Cosplay Complex
Cowboy Bebop - Knockin' on Heaven's Door [BD 1080p] [10 bits]
Cowboy Bebop [Blu-ray 720p]
Coyote Ragtime Show
Crayon Shin-Chan Movie 01 Unkokusai no Yabou
Crayon Shin-Chan Movie 02 The Secret of Buri Buri Kingdom
Crayon Shin-Chan Movie 05
Crayon Shin-Chan Movie 08
Crayon Shin-Chan Movie 09 The Adult Empire Strikes Back
Crayon Shin-Chan Movie 10
Crayon Shin-Chan Movie 11
Crayon Shin-Chan Movie 12 Arashi wo Yobu! Yuuhi no Kasukabe Boys
Crayon Shin-Chan Movie 17 Otakebe! Kasukabe Yasei Oukoku
Crayon Shin-Chan Movie 18 [HD 720p]
Crayon Shin-chan movie 20 Arashi o Yobu! Ora to Uchū no Princess
Crayon Shin-Chan Movie Action Kamen vs Haigure Mao
Crest Of The Stars - Birth
Crest Of The Stars - Seikai No Monshou
Crest Of The Stars - Seikai No Senki I
Crest Of The Stars - Seikai No Senki II
Crest Of The Stars - Seikai No Senki III OVA
Cross Game [HD 720p]
Crusher Joe
Crusher Joe OVA : The Ice Prison
Crusher Joe OVA : The Ultimate Weapon Ash
Crying Freeman
Crying Freeman The Movie
Crystal Blaze
Crystal Triangle
Curse Of The Undead Yoma
Cuticle Detective Inaba [HD 720p]
Cyber City Oedo 808 OVA
Cyberteam in Akihabara - 2011 Summer Vacations
Cyclops Shoujo Saipu [HD 720p]
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}