// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\s*|\(([^()\r\n]+)\)").unwrap();
let string = "(C,D) (E,F) (G,H) (J,K)
(C,D) (E,F) (G,H) (J,K)
((C,D) (E,F) (G,H) (J,K)";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}