$re = '/([a-zA-Z][\w\-_.:]*)\s*=\s*"(([^\\\\"]|\\\\"|\\\\)*)"/m';
$str = '<a href="asdfds\\"\\"" test-bkk99="123" href="asdfds\\"\\""
>absdf</a>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);