package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\/u\/(\w+)`)
var str = `/u/USERNAME
/u/ExaMp1e`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}