$re = '/\b(java|php|c#)(?=[^a-z0-9_]|$)/mi';
$str = 'Java
C#
PHP';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);