package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).cde.`)
var str = `First nine letters are abcdefgeh`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}