import re
regex = re.compile(r"^[ \t]*(?>etaLearnW_enabled)[ \t]?=[ \t]?(?<etaLearnW_enabled>[01])[ \t]*[ \t]*;?", flags=re.MULTILINE)
test_str = ("%% LEARNING RATES and other HYPER PARAMETERS\n"
" lambdaInfomaxTerm = 1; %coeff before logdetT'T, 0 or 1\n"
" \n"
" etaLearnW_enabled = 1;\n"
"etaLearnW_enabled = 1;\n"
"% etaLearnW_enabled = 1;\n"
" %etaLearnW_enabled = 1;\n"
" etaLearnW = 1E-4;\n\n"
" %lambdaRidgeW = 3e-3; %going down, crashes on epoch 3888\n"
" lambdaRidgeW = 3e-2;\n"
" \n"
" etaLearnK_enabled = 1;\n"
" etaLearnK = 4E-5; \n"
" \n"
" %PostSlim:\n"
" %lambdaRidgeK = 3e-5; %too weak (going down fast)\n"
" %lambdaRidgeK = 3e-4; %too weak (fails at #14628)\n\n"
" lambdaRidgeK = 1e-3;")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")