package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\/[^@]*)(?:.*)?`)
var str = `/echo@gram_bot
/echo
/echo@whatever`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}