$re = '/(?<=(?\'q\'[~\/]))\w+?(?=\k\'q\')/m';
$str = '~g~ ~recsd~ v ~fdvdf
~vdfv~ fvdv ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);