$re = '/\d{2}(?!\d|.*\d{2})/m';
$str = '123f64swfW68F43
123f64swfW6843
123f64swfW6843sad
123f64swfW6843sa3d';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);