package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[^\d\s-\/]`)
var str = `tetes / etset 123215 - camos numeros | espaço | barra (/) | traço (-)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}