$re = '/"(?:(?:(?!(?<!\\\\)").)*)"/';
$str = 'Regex should return "String 1" or "String 2" or "String3" and "\\\\"double quoted string\\\\""';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);