$re = '/CN\s*=\s*(.*?)(?= |,).*/';
$str = '"CN=bbb1, OU=b, O=b, L=b, S=b, C=US"
"CN=*.host.com, OU=b, O=b, L=b, S=b, C=US"
"CN = *.host.com "
"CN = bbb1 "';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);