using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?!<span style=""background-color: #([A-Fa-f0-9]{6}|[A-Fa-f0-9]{3})"">|<\/span>)[&<>""'/])";
string input = @"<b>some test <span style=""background-color: #333300"">ol string!</b></span> nope <i>whoops</i> <span style=""background-color: #ff0000"">meh</span>
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}