$re = '/(["\'])[\S\s]*?\1|(["\'])(?:\\\\\2|(?!\\\\\2)(?!\2).)*\2/m';
$str = '"message: \\"" + message + "\\".
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);