$re = '/[aeiouyAEIOUY]+(?!(?<=[eE])[^a-zA-Z]|$)/m';
$str = 'Three encyclopedia, that they madEh he he.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);