package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\.bubu\s*{.*?}`)
var str = `.bubu {color: red;} .dudu { moo; }`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}