$re = '/^\$\d+(?:\.\d{2})?$/m';
$str = '$7.26
$48.49
$17
$.49
$192.9';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);