import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "https://internetinthecar-e2e\\.((sfr|a1|swisscom|proximus|elisa|tango|telenor-no|telenor-se|yousee|plus|telia|bite-lv|bite-lt|a1-)\\.)?iot\\.vodafone\\.com/sso/authorize/callback|https://internetinthecar-e2e-new\\.iot\\.vodafone\\.com/sso/authorize/callback";
final String string = "(https://internetinthecar-e2e.iot.vodafone.com/sso/authorize/callback|https://internetinthecar-e2e.sfr.iot.vodafone.com/sso/authorize/callback|https://internetinthecar-e2e.a1.iot.vodafone.com/sso/authorize/callback|https://internetinthecar-e2e.swisscom.iot.vodafone.com/sso/authorize/callback|https://internetinthecar-e2e.proximus.iot.vodafone.com/sso/authorize/callback|https://internetinthecar-e2e.elisa.iot.vodafone.com/sso/authorize/callback|https://internetinthecar-e2e.tango.iot.vodafone.com/sso/authorize/callback|https://internetinthecar-e2e.telenor-no.iot.vodafone.com/sso/authorize/callback|https://internetinthecar-e2e.telenor-se.iot.vodafone.com/sso/authorize/callback|https://internetinthecar-e2e.yousee.iot.vodafone.com/sso/authorize/callback|https://internetinthecar-e2e.plus.iot.vodafone.com/sso/authorize/callback|https://internetinthecar-e2e.telia.iot.vodafone.com/sso/authorize/callback)\n\n\n\n"
+ "https://internetinthecar-e2e.bite-lv.iot.vodafone.com/sso/authorize/callback\n"
+ "internetinthecar-e2e.bite-lt.iot.vodafone.com\n"
+ "internetinthecar-e2e.a1-si.iot.vodafone.com\n"
+ "internetinthecar-e2e.cyta.iot.vodafone.com\n"
+ "internetinthecar-e2e.elisa-ee.iot.vodafone.com\n"
+ "internetinthecar-e2e.epic.iot.vodafone.com\n"
+ "internetinthecar-e2e.a1-hr.vodafone.com\n"
+ "internetinthecar-e2e.a1-bg.iot.vodafone.com\n\n\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}