package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^0[1-9][0-9]{8}$`)
var str = `06193319930`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}