re = /\{\"\w+\":\"\w+\",\"(?<response_values>[^\"]+)/m
str = '[{"type":"A","response":"52.7.102.57","asn":"14618","asname":"aws"},{"type":"A","response":"52.71.245.135","asn":"14618","asname":"aws"}]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end