re = /(?<=\b[^\Wd]*)d/m
str = 'fuunnynsdfdn dfdfomdfdnd dfdfnntr ndfdf thatnfdfdfdfd'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end