$re = '/^[a-zA-Z](?=.*[A-Z])(?=.*[a-z])(?=.*[0-9]).{4,6}$/';
$str = 'RRr7RR';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);