const regex = new RegExp('^(?P<unit_type>LS1376)(?P<spool_symbol>X201)(?P<sep_1>-)(?P<unit_series>1X)(?P<sep_2>/)(?P<pilot_valve>10S)(?P<solenoid_in_ac_or_dc_version>G)(?P<voltage_of_solenoid>12|24|42|96|110|205|220)(?P<manual_override_unit>N9)(?P<electrical_connection>K4)(?P<sep_3>/)(?P<orifice_positon>B)(?P<orifice_diameter>22)(?P<seal_material>V|)(?P<additional_details>)$', 'gm')
const str = `typecode
LS1376X201-1X/10SCG220N9K4/B22V
LS1376X201-1X/10SCG110N9K4/B22V
LS1376X201-1X/10SCG24N9K4/B22V
LS1376X201-1X//V
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}