$re = '/!~?[A-z\d]{8}@/m';
$str = '!~z3040d4B@';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);