$re = '/(.*)::/m';
$str = '3001:470:8865:2E01::190:201';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);