package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)\Ab'(.*)'\Z`)
var str = `b'{"a": 1, 'b': 2}
'`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}