$re = '/\b\w*\b(\sy)\b/m';
$str = 'this is my theor y of dance
where did you send your inquir y?';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);