re = /[-+]?\b(?<!\d\.)\d+\.\d+\b(?!\.\d)/m
str = 'Test string 1.234 0.155.1 5.67799350,-2.654657'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end