$re = '/^[-+]?\d*.?\d*$/';
$str = '120
45
-56
30.5
-19.0';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);