use strict;
my $str = ' Georgiana, Mary Louise Gettemy, Blanche Getz, Donald Eugene Gibboney, Josephine Marie Giffin. Harriet Vivian Gill, Marjorie Rita Gill. Dorothy Elizabeth Margherita Gioiosa. Audrey Gleichert, Annabelle Louise Glenn, Ethel Louise Glenn, David R. Good, Peggy Louise Good. Frank Edward Goodman, Jr., Ray L. Goodman, Eleanore Jane Gorsuch, Richard S. Goshen, Oliver E. Graffius, Max R. Gram- ly. Eunice Mae Granville. Clifford Harry Gray, Marian Elizabeth Gray, Sara Jean Gray, Jeanne Lovina Grazier. . Dorothy Elizabeth Green. Doris Marie Greene, Gertrude Elizabeth Greiner, Virginia M. Greiner, Hazel A. Griffith, Sarah Lee Grimshaw, Dottie Louise Grove, Helen Almeda Grove, Jean. Jie Louise Grove, William Sharr.n Grove, Pauline Antoinette Gug-liotta, Harold Frederick Gundei, Helen Gertrude Gundei, Edythe Irene Gunesch, Louise Alma Gun- eallus, Robert Wesley Gutshali. Lillian Esther Haberstroh, Dorothy Jean Hack. Harry Haines, Jr. Paul Francis Hainley, David L. L. Hall, Helen Beatrice Hall, Phyllig Joyc. Hall, Anna Marjorie Hailer, Frank L. Hamer. Sarah Louise Hamilton, Vivian Annetta Hammaker, Walter J. Hammer, Virginia Esther Hana-walt, Pauline Elizabeth Hancuff. Elvin E. Hanley, John Lee Harkenrider, Jack Harkless, Ida Josephine Harland, Jack G. Harlin, Stoy Ottig Harman. Willard Kistler Harnish, Albert Donald Harris, Betty Bell Harris Jesst Melvin Harris, Richarj Thomas Harris, Roxie Anna Harris, Ralph Derr Harrity, Eiieen Hart, Dale Charles Harten, Janet Louise Harten, Alice Jane Har.-sock, Thomas Eldon Hislett, James Lewis Hatch, Bessie Mae Haupt, Bernadine L. Hawn, Peggy Heaps, Ellis Theodore L. Hed-berg. Sara Elizabeth Heinbaugh, Flora Cardinal Heist, Dorothy M. Heller, Ear Randell Helsel, Graham W. Helsel. Naomi Genevieve Helsel, Wanda Gertrude Helsel, William Richard Hennigan, Charles Wayne Henry, Naomi Jean Herbert, Robert Rogers Herr, Ann Marie Hess, Martha . Hicks, Richard Joseph Higgins, Alden Frederick Hile-man, Dorothy Marie Hileman, John Stuart Hileman, Allene Mar ie Hill, Dorothy Winifred Hippo, Alice Frances Hirst, Charles John Hoefler, Allan Milton Hoffman, Charles H. Hoffman, Cleo Louise Hoffman, Winifred Ore Lee Hoff man, George William Hogue, Jr., Robert Leroy Holdeman, Elsie Marion Hollingsworth, Vincent Clair Hooper, Constance Hoover. Alvin Merle Horton, Betty Louise Horton, Richard Ernest Hostler. Dalton Edward Householder, Gretchen L. Houser, Helen Vir-srinia Housner. Florence Vivian Houston, John Robert Housum, George D. Hower, Helen Louise Huber. Paul Mark Huebner, Mar garet Ann Hughes, John L. Hume, Bettv Humerick. Elsie M. Hum. Bettv Jane Ihm, Jonn Meivin Ihm, Gladys A. Ingham, isaivaaore Rocco Iovannone, Wilbur Edwin Irvin. Victor Anthony Iuliano, J. Edmund Ivory. JoseDh Jacobs. Wilbur tr. Jami son, Albert John Janosik, Joseph Michael Jerkiewicz, Mary Eliza beth Jeffries. Joseph John Jerk- ovitz, Edwin George Johnson, Har ry Curry Johnson, Miriam Louise Johnson. Jack Jones, Jr., Bernard James Joyce. Sarah Irene Kantner. J. Mareuret Karle, Beatrice Viola Kauffman, Peggy Rosalie Kauffman, Robert Logan Kauff man, Brooks D. Kauffman, Wil liam R. Kauffmann, Virginia Elizabeth Kay. Bette Jan. Kaylor, Mary Eliza beth Keagy, Myrtle Clara Keagy, Dorothv M. Kearns, William Jo- ReDh Keen Frances Aileen Keech, Constance Louise Keirn, Jean Lo uise Keith, George Arthur Keller, Mervin Edward Keller, Marie Kathryn Kelley, Lawrence Robert Kells. Emilv Rose Kelly, Mary Elizabeth Kembeiling, Janet Mar ie Kemmler, Betty Irene Kensing- er. Marjorie Jean Ketrow. Martha Yvonne Kibler, Wini- fie.M Kile-ore. Gertrude Agnes Kimmel, William P. Kimmel. Rohei Nelson King\\r\\nWilliam Kinnev. Phyllis Patricia Kiser\\r\\nThaddeus J. Kisielnicki. Paul Harrv Kleffel. Ruth Kath leen Kline. Flovd Blair Knipple\\r\\nJr.\\r\\nDorothy KniseQ\\r\\nVivian Mar ti Knote. Helen Man. Koch\\r\\ni\'aui Michael Koch\\r\\nHerman J. Koest. ner Pauline Marie Kolbenschlag\\r\\nNela Jean Koontz. Edward L. Kough\\r\\nGeorge Koury\\r\\nChristine Paula Kowell\\r\\nJean Elizabeth Kozam\\r\\nmarina Ellen Kraft, Charles Edward Kramer. Robert Daniel Kreider, Kenneth M. Krise, Harriet Sue Kromberg, Bernice Arline Kunn, Melvin Floyd Kuhn, Roy Earl Kunkle. John F. Kunstbeck, Bette Flor- ine Kyle. Norma Madeline LaCava, fns- cilla M. Laing. F. Luella Langer, Betty Lang- guth, Warren Elwood Lantz. Minnie Marv Laratonda, Velda Betty Lasher, Betty Jane Lathero, David Lattieri. Glenn Francis Laughlin, Robert David Laughlin, Joseph Lawruk, Marjorie Rose Leasure, John Albert Leberfinger, Clement George Lehrsch, Paul Vincent Leidy, Mary Jane Lemme, John Richard Leonard, Virginia Ann Lepore. Arnold Robert Levine. Doris B. Lewis. Dorothv L. Lewis. Herbert Clyde Lewis, Naomi Etter Ley, Alya Anne Lickel, Bertha Mae Lal- Erma Delores Lindemer Rulh Ellen Lindie, Idabelle Lingenfelt-er. Pearl Aurirev T,inffpnflttr Carmen Elayne Little, Mary Dolores Livot, Elizabeth Jane Lock-ard, Raymond Earl Lockard, Cla ra cridget Loeb. Bettv Loin Rdni T r, r Hazel Trene ..B , wt a, ivuvii Long, Shirley Long, Esther Eliza- uem iouaensiager, John Emanu-ei Love, Olivette Eleanor Love, Norma E. Lowey. Dennis Gordon Loynes, Stella Josephine Lozinski, Raymond S. Luke, Joseph Lurie, Raymond Arthur Luther, Kennt:i B. Lyk-ens, Lillie Irene Lyktns. Virginia Maa Lytle. Catherine Elizabeth McAllister, James Arthur McCall, Robert E. McCartney, Jr., Thomas W. Mc-Clellan. Anna Elizabeth McCormick. Margaret Mary McCracken, Joseph Edward McCulloch, E. Grace McDowell, John Dean McDowell, Virginia Anne McDowell, Pauline McGarvey, Leon Russel McGeary, Mildred Alice McGirk. Eugene E. McGregorf Helen Louise McGregor, John Fiske Mc-Hugh, Clara Elizabeth McKee, Constance Lucille McKnight, Robert F. McManamy, Eleanor Jeanne McMinn, Dorothy Mae McMonigal. Jane McMamara, Mary Elizabeth McNerling. Raymond F. cQuade. Betty Jayne Mackey, Helen Elizabeth Mackey. Patsy Albert Mainello, Yolanda Marie Maiorino, Samuel Guy Ma-lone, Rose Marie Mangiacarne. J. Warren Manley, Dorothy Mae Manning, Harold Mannion, Bette Lorraine Manspeaker, Kanalla Louise Marcus, John Lucas Marshall, Margaret A. Marshall, Frances Marie Marthoski, Albert Irvin Martin, Alice Rebecca Martin, Marjorie Maxine Martin, Carmel Mary Martino, Jack Duane Martz, Lyman Martz, George Joseph Maschke, Richard Joseph M. Mast-erson. Lena Patricia Masucci. Ken neth James Mater, Doris J. Hath- Helen Grace Mehaffie,\' Michael John Melnick, Kenneth J. Mentch, William H. Mentch, Anna Gertrude Mentzer, Lois Elizabeth Mentzer, Robert Edwin Mentzer, Nad John Meredith, Belva Louise Merritt, Bertha Jean Metzger, Joseph Calvin Meyer, Betty Louise Mickel, Robert Doyle Mierley, Allen J. Miller. Charles Edward Miller, Dorothy Elizabeth Miller, Georgine Collins Miller, Jean Ann Miller, Joseph Calvin Miller, Lester A Marjorie Jane Miller, Miller, Samuel Ward Miller. John Joseph Misciagna. George Franklin Mock, Herbert Earl Mock, Ruth Evelyn Mock, Jane Lilian Moerschbacher, Ercole Ralph Moffa, Lena Mazie Mollica, Betty Jane Moore. Erraa Jean woreui, Marjorie Elizabeth Morgan, Patty Jean Morgan, Daniel Henry Moses, John M. Mottner, Alma Catherine Moyer. Josephine Muccitelli, Louis D. Muccitelli, Ernest M. Musselman, Marian M. Musselman, Marian Lucille Musser, Nancy Louise Mus-ser, James Porter Myers, Jr., Richard L. Myers. Betty Madeline Nader, Angela Petronilla Nagl. Marcella B. Naperkoski, Tony Joseph Nardella. Martha Audrey Neaffer, Elwood Clair Nearhoof, Lois Mae Near-hoof. Martha E. Neher, Jean Eleanor Nelson, Ruth Marie Neugebauer, Paul Joseph Nevedal, Imogene Fern Nicodemus, Josephine Naomi Nixon, Frank Edward Noel, Lela Audrey Noll. Madalyn Vera Noriis. Nellie North, Pauline Frances Novosel, Robert. Melvin Nowlen. Jack W. Ogden, Annastasia S. Olkowski, Dorothy Ollinger, Caroline Rose Orner, Jayne Kathleen Osner, Dorothy . Irene Ostrander, Dolores Catherine Oswald, Frances E. Oswald. Harry Leroy Otto, Jr. Marguerite Grace Overcash, Robert Roy Owens. Eva Jayne Packer, Winifred Patricia Paff- Helen E. Palovsky, Eva Bessie Panagos, James William Panos, Harry L. Parrish, Jr., June A. Parson, Virginia Ellen P arsons, Mary Jane Patronik, Amelia Marie Pavoni, Robert Ellsworth Pearce. Don Miguel Peoples, Matilda Mary Pepe. David Lee Peters, Retta Belle Peters, Ernest Leroy Peterson, Wayne Bennett Pheasant, Jayne Louise Phillips, Arthur Paul Piet-rolungo, Angeline Pietropaulo. Nellie Frances Piotrowski, Andrew Michael Pirro, Frances Kathryn Pizzino. Richard Anthony Plank Ra pearl Plummer, Leo Francs Plunket. Marcella Fiances Poppenwimei, Janice EUen Porta, Thelma Re-genia Porta, .Marjorie Butler Porte. , , Mary Elizabeth Porter. Roberta Elizabeth Porter, Frank Emanuel Prestipino, Webster 1. Pringle, T?eHv Louise Probst, Frank Xavi- er ProgL Viola Ann Prosperl, Jack Wayne Pruyn, Vincent A. Pucciar- ella Antoinette Virginia Pulici- chio. Bernice Marie Quirin, Charles Quirin. Betty J. Raber. Carley Mae Rager. Edward G. Raichle. Jeanne Beatrice Ramey, Michael Rapuano, David John Ben Roy Rath, Madalyn Louise Redline, Iris Adele Reed, Margaret Rebecca Reed, Richard Thomas Reed, Wallace E. Reed. Betty Jane Reid, Norma Helen Reish, Betty Louise Richards, F. Marguerite Richards, Ruth Fouse Richards, Dolores Jane Ricko, Grayce B. Rider, Lois Joan Riley, Marjorie Marie Riley, Edna Rita Riner, Anthony Rlspoli. Germaine Ritchey. Rosie Dorothy Rizzo, Mary Edna Robinson, Dolores Corrone, Robison, James Joseph Rock, Lu cille Minerva Rockey, Robert Rod- gers, Caroline C. Roefaro, Elizabeth June Rohe Roy W. Rom-berger, Dolores Jane Rorabaugh, Frank Vincent Roscio, Irene Lois "r ir . . sc, margaret jean nosenDerg- er, Charles Ulysses Ross, Jr., Lois E. Ross. Rosalie Margaret Rosskopf, H. Lloyd Roudabush, Nina Ruth Rouzer. Joseph B. Ruberto. Marie Antoinette Rubino, Der-wood Calvin, Rudasill, Paul B. Runyen, Esther Lorraine Run-yeon, Jeanne Anne Runyeon, Marjorie Ruth Rupe, Mary Louise Rupert, Marcella M. Russell, Walter Kenneth Russel, Patricia Margaret Ryan. Edward L. Sabatina, Elizabeth Helen Samuels, William J. Sanders, Rose Marie Savine, Matilda Savino, Horace S. Saylor," Marian Saylor, Warren Clyde Schadle, Dolores Marie
Schaefer, Theresa Sophie
Schamris, Martha Anna
Schauer. Mary Patricia
Schell, Herbert Anthony
Scherzinger. Richard Lewis
Schlehr, Ruth Ella
Schoening, Conrad Edgar
Schorner, Ernest Joseph
Schorner, Dorothy Marguerite
Schroeder, Leroy Arthur
Schroth, Sidney
Schulman, Yale
Schulman, Gertrude Conisea
Schultz, Melvin Charles
Schwartz, William Thomas
Sciarrilla, Shirley Ann
Scott, Vivian M.
Scott, Walter Douglas
Scott, Nellie Jane
Secse, Eleanor Mae
Seidel, Louis William
Seidel, Helen Jeanne
Selwitz, Edith Rose
Ser-venti, Sarah Elizabeth
Shaal, Kermit Nelson
Shaffer, Fred
Shaheen. John Paul
Sharer, Richard W.
Sharer, Thomas William
Sharrar. Virginia E.
Shartle, Stewart Dean
Shaver, Phyllis Elaine
Shaw, Leo-na Marguerite
Shellenberger, Laurence Nelson
Shelley. Sara Jan.
Shollar, Gloria Marie
Shortino. Marie Jane
Shubert. Betty Marguerite
Shull, Mary Elizabeth
';
my $regex = qr`([\s]+)([A-Z]+[a-z]+[,][\s])`p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}