re = /\\AppData\\Local\\Temp\\[a-zA-Z0-9]{0,8}-[a-zA-Z0-9]{0,4}-[a-zA-Z0-9]{0,4}-[a-zA-Z0-9]{0,4}-[a-zA-Z0-9]{0,12}\\G2MInstaller.exe/m
str = 'C:\\Users\\PDELGADO~1\\AppData\\Local\\Temp\\8FFA79F7-BBCD-4D73-903C-B8A82FC482B0\\G2MInstaller.exe'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end