import re
regex = re.compile(r"[\(\)()]")
test_str = "abcdwadwadadaabc()dwadwadwad()()"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)