use strict;
my $str = 'Ala ma 2 koty oraz 4 psy i coś jeszcze
Ala maaa 2 kotycc oraz 4 psy ibb coś jeszcze
Ala ma 2 koty cc oraz 4 psy aa i coś jeszcze bb
Ala ma 2 kotycc orazbb 4 psy i cośaa jeszcze
Ala ma 2 kotydd orazbb 4 psy i cośaa jeszcze
Ala ma 2 koty aaoraz 4 psyaa ibb cośbb jeszczecccc
';
my $regex = qr/(.*(aa|bb|cc){1}){3}/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}