$re = '/^[a-z0-9._%+-]+@nter\.es$/m';
$str = '@nter.es
miguel@nter.es
d@nter.es
HOLA@nter.es';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);