$re = '/\b(\d+)\b/m';
$str = 'text1
1 5 7
hello world 5. This is Samurai 10 not samurai10.
text2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);