$re = '/(?<=\[)
(?:
\\\\{2}
(?:[^\\\\]|\\\\{2})
|
[^\]]
)+
(?=\])/mx';
$str = '+------------------+----------------+
| Input | Output |
+------------------+----------------+
| [B] | B |
| [B][C][D] | B |
| [hello\\t\\tworld] | hello\\t\\tworld |
| [hello\\n\\nworld] | hello\\n\\nworld |
| [\\\\]] | \\\\] |
| [\\\\\\\\] | \\\\\\\\ |
| [x[y\\\\]z][foo] | x[y\\\\]z |
+------------------+----------------+';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);