package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([-\w]+).php`)
var str = `www\header-template.php`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}