re = /([^,\s\{=]+)=([^,]*)(?=,|\})/m
str = '{af_sub1=1.5, af_deeplink=true, campaign=None, media_source=None, install_time=2018-05-08 03:34:34, af_status=Non-organic, path=, scheme=, host=}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end