re = /(Element CI: )\d{4}/m
str = 'Aditional bt account data: No
Element CI: 1234'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end