re = /(?<key>[\w\s]+:)\s*(?<value>.+?)\s*(?=(?:[Aa]rtist|[Tt]itle|(?:[Ff]ramed )?[Dd]imensions):|$)/
str = 'Artist: foo Title: bar Dimensions: x Framed dimensions: y'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end