using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"fmc=""(.*?)"".*?<part.*?>(.*?)</part>";
string input = @"<?xml version = ""1.0"" encoding=""UTF-8"" standalone=""yes"" ?>
<corpus>
<ver id=""18"" etude=""EC1_Elec"" elec=""oui"" niveau=""1"" critere=""1.3"" type=""discours"">
<part code=""EC1_Elec_IW04_0"">Ça existe sur des gros parcs Hlm mais c'est macro.</part>
</ver>
<ver id=""30"" etude=""EC1_Elec"" elec=""oui"" niveau=""2"" critere="" origine=""IW"" type=""discours"" fmc=""motives"">
<part code=""EC1_Elec_IW01_0"">Avant 75 on n'a pas isolé puis après, au fur et à mesure des règlementations.</part>
</ver>
<ver id=""54"" etude=""EC1_Elec"" elec=""oui"" niveau=""1"" critere="" origine=""IW"" type=""discours"" fmc=""condition"">
<part code=""EC1_Elec_IW10_0"">Le deuxième boitier, il est où ? s'il y en a un qui est à l'intérieur et qui remplace un bout de l'isolation, il est caché OK.</part>
</ver>
<ver id=""897"" etude=""EC3_Elec"" elec=""oui"" niveau=""4"" critere=""4.1"" origine=""TR"" type=""discours"" fmc=""obstacle"">
<part code=""EC3_Elec_TR2_1"">Avec l'économie d'énergie, on va imposer de plus en plus d'automatismes,</part>
<iwer>Çava influencer la demande pour ce type de solution c'est ça ?</iwer>
<part code=""EC3_Elec_TR2_1"">Je pense oui</part>
</ver>
</corpus>";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}