$re = '/^(?:\d(?=\d*\*?\d*(?:[ ,;]|$))[\d*]{0,9}(?:[ ,;]|$))+$/m';
$str = '1234567890,123456*90,6123
*012345678,1234567890
12345678*90;12345677
1234567890 3
123* 12 2*';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);